lzth.net
当前位置:首页 >> 为什么sql sErvEr 高版本的数据库不能附加低版本 mDF文件? >>

为什么sql sErvEr 高版本的数据库不能附加低版本 mDF文件?

no no no 是低版本的数据库不能附加高版本的mdf文件,高版本的能附加低版本的!建议你在原来的服务器上做一个全备份,.bak文件, 然后再 restore 到现在用到的服务器数据库上.

没法降,可用数据导入导出功能,或由高版本生成低版本兼容脚本

这个没有办法了,只能安装高版本的SQL进行处理.

2000 以后,拷贝mdf和ldf文件到一个文件夹,然后在2005以上的management studio中,在“数据库”击右键,附加 拷贝的mdf文件.2000以前的6.5/7.0数据库,差异较大,很难附加,

您好:sql server向下兼容的.直接附加就好啦.

你的计算机是不是有多个用户,多个用户的话,桌面文件夹也是有多个的.你直接打开 C:\Program Files\桌面 看下有没有你的mdf文件

可以去默认存储数据库文件的文件夹里去找找..你应该只是设置了mdf文件的路径,ldf没有设置

高版本不能附加到低版本的SQL引擎上

将要附加的文件拷贝到 SQL Server 默认的 Data 目录,此时附加就会成功

你本机的数据库版本比你这个主数据文件的版本低 所以报错 建议楼主升级你自己的数据库 也可以直接安装高版本的数据库 你可以在你要附加的数据库服务器上执行select @@version 查看一下版本信息然后安装这个版本或更高的版本 有什么问题可以上网随时找我 希望采纳

网站首页 | 网站地图
All rights reserved Powered by www.lzth.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com