lzth.net
当前位置:首页 >> 易语言 删除配置项 如: [A] A=1 怎么把他们都从in... >>

易语言 删除配置项 如: [A] A=1 怎么把他们都从in...

容易,用写配置项 (文件名,“A” , , )将A节名称的配置项名称替换字文本

既然你知道读写配置项,那我就只说思路。 直接把这一项读出来,然后文本分割好,再写回去! 挺简单吧!

.版本 2.局部变量 文本, 整数型文本 = 读入文本 (打开文件 (“你配置文件的目录”, , ), )文本 = 文本_替换 (文本, , , , “a=1”, “”)写到文件 (“你配置文件的目录”, 到字节集 (文本))精易模块嗯也许还有更好的办法

.版本 2 .局部变量 节名称, 文本型 读配置项 (“路径”, 节名称, , ) .如果真 (节名称 = “ ”) 写配置项 (“路径”, , , ) ' 清空数据 .如果真结束

.版本 2 .局部变量 保存, 文本型 .局部变量 临时文本, 整数型 .局部变量 计次变量, 整数型 通用对话框1.打开 () 保存 = 通用对话框1.文件名 写配置项 (取运行目录 () + “\1.ini”, “test”, “txt”, 保存 + “,”) 临时文本 = 分割文本 (读配置项...

版本 2 .子程序 _按钮1_被单击 .局部变量 文本, 文本型 文本 = 读配置项 (取运行目录 () + “\1.ini”, “大”, “斜, ) 写配置项 (取运行目录 () + “\1.ini”, “大”, “斜, 子文本替换 (文本, 编辑框1.内容 + “|”, , , , 真))

系统说明里面有提到 写配置项 (文本型 配置文件名,文本型 节名称,[文本型 配置项名称],[文本型 欲写入值]) 参数的名称为“配置项名称”,类型为“文本型(text)”,可以被省略。参数值指定欲写入配置项在其节中的名称。如果参数值被省略,...

写配置项的时候 欲写入的值不填就对了

.版本 2 .子程序 _按钮1_被单击 .局部变量 文本, 文本型 文本 = 读配置项 (取运行目录 () + “\1.ini”, “大”, “斜, ) 写配置项 (取运行目录 () + “\1.ini”, “大”, “斜, 子文本替换 (文本, 编辑框1.内容 + “|”, , , , 真))

网站首页 | 网站地图
All rights reserved Powered by www.lzth.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com